Windows 8 – DVD-Laufwerk wird nicht erkannt

Die Testversion von Windows 8 hatte ich mit Ausnahme der Apps die dort nicht aktiv waren bereits ausgiebig testen können. Seit Freitagabend läuft hier die Vollversion von Windows 8 64-bit Professional. Der Umstieg mit dem “Umweg” über eine Neuinstallation von Windows 7 und dann dann Windows 8 Upgrade dauerte gerade mal 65 Minuten.

Alle Geräte wurden ordentlich erkannt und liefen wie bereits bei der Preview-Version auf Anhieb ohne das Einlegen von Treiber- oder Software-CD ´s.

Bei der Installation der übrigen Software kam dann zunächst eine kleine Ernüchterung. Obwohl das Upgrade von Windows 8 von einer DVD installiert wurde – das Laufwerk wurde als richtig erkannt und war auch funktionsfähig – ist das DVD-Laufwerk jetzt unerkannt und verschwunden.

Weder im Explorer noch im Gerätemanager wurde das Laufwerk angezeigt. Eine Kontrolle im BIOS ergab, dass das DVD-Laufwerk definitiv vorhanden ist. Alle Versuche das Laufwerk anzusprechen blieben ergebnislos. Nach einer sehr langen Recherche fand ich diese Lösung.

Aktivierung des CD -/DVD-Laufwerks unter Windows 8

Die Eingabeaufforderung muss als Administrator geöffnet werden. Dazu klickt man gleichzeitig auf die Tastenkombination Windowstaste+W, schreibt in das sich öffnende Suchfeld “Eingabeaufforderung”. Unter der Rubrik “Apps” wird diese angezeigt. Hier klickt man mit der rechten Maustaste auf die App (so heißen jetzt alle Anwendungen bei Windows), am unteren Ende des Bildschirms klickt man dann auf “Als Admin ausführen”.

Eingabeaufforderung

Eingabeaufforderung Windows 8

Dort gibt man den nachstehenden Befehl ein. Am einfachsten hier per STRG+C kopieren und in der Eingabeaufforderung mittels rechter Maustaste einfügen.

reg.exe add "HKLM\System\CurrentControlSet\Services\atapi\Controller0" /f /v EnumDevice1 /t REG_DWORD /d 0x00000001

Den Befehl mittels Eingabetaste bestätigen und die Eingabeaufforderung mittels dem Befehl “exit” wieder verlassen. Jetzt den PC neu starten.

Anschließend wurde das Laufwerk richtig erkannt und funktionierte einwandfrei – warum also nicht gleich so. Ein bisschen vom “alte Windows-Gehampel” musste eben doch noch sein smilie .

Alle hier beschriebenen “Operationen” führt natürlich jeder in eigener Verantwortung durch, eine Haftung dafür wird nicht übernommen.

Autor  ⁄ Thomas Liedl

Meine digitale Vergangenheit reicht fast bis zur Geburtsstunde des Internets zurück. Nach zahlreichen anderen Webseiten bin ich letztlich im März 2007 in die Welt des Bloggens eingestiegen. Ich beschäftigte mich mit gemischten Themen aus Gesellschaft, Politik, Technik und Sport. In meinen Praxistests schreibe ich über eigene Erfahrungen mit Produkten bzw. Dienstleistungen im Netz.

29 Kommentare

  • Antworten
    Hottentott
    31. Oktober 2012

    Hallo Herr Liedl,

    vielen Dank für diese hervorragende Anleitung!

    Jetzt wird auch mein DVD-Laufwerk unter Windows 8 wieder erkannt und funktioniert problemlos.

    • Antworten
      Thomas Liedl Autor
      31. Oktober 2012

      Willkommen bei Nicht spurlos, Hottentott. Nichts zu danken, wenn ich jemandem anderen den längeren Rechercheweg ersparen kann hat sich der Artikel schon gelohnt smilie . Es taucht ja merkwürdiger Weise nicht bei allen Neuinstallationen auf, so ein bisschen “ärgern” muss eben sein.

  • Antworten
    1. November 2012

    Ich habe Windows 8 auf ein komplett neues Laufwerk installiert. SChon vor Wochen. Bei mir ging es ohne Probleme.
    Nur bei Logitech hatten sie noch keine Webcam-Treiber für Windows 8- Mit einen kleinen Umweg konnte ich die alten Treiber installieren und alles klappt sehr gut, ebenso wie das ganze System.
    Das alte Startmenü habe ich bisher nur in den seltensten Fällen vermisst. Aber es geht auch ohne.
    Tastaturkürzel, Dateinamen und andere Kleinigkeiten zu wissen, können nicht schaden.
    Nur kann man das von “Otto-Normal-Verbraucher” verlangen?
    Windows 8 ist eben eine Gratwanderung zwischen Desktop und Mobilität. smilie

    Vieleicht ist der Fehler beim Upgrade zu suchen. Da kann es durchaus sein, das sich Treiber in die Quere kommen. smilie

    LG Timm

    • Antworten
      Thomas Liedl Autor
      1. November 2012

      @Timm:

      Nur kann man das von “Otto-Normal-Verbraucher” verlangen?

      Ich würde mal sagen ja, denn die Technik setzt auch einen gewissen Lernprozess voraus den man haben sollte – nein haben muss. Nimm die heutigen Mobiltelefone als Vergleich. Wären diese immer noch im Entwicklungsstand von 1999 gäbe es kein WLAN, keine Apps und keine Fotografie in den Geräten. Gleiches gilt für die Kartenzahlung (EC, VISA & Co.). Vor 30 und mehr Jahren hätte auch niemand geglaubt, dass man heute an der Tankstelle mit Plastikkarten bezahlt.

      Man muss natürlich nicht mit Karte zahlen. Doch irgendwann kommt der Tag, da geht es gar nicht mehr anders. Und dann werden auch die Kritiker erkennen müssen… der Fortschritt ist nicht aufhaltbar.

      Die angesprochene Gradwanderung gehört mit dazu. Wer stets ein klein wenig am Ball bleibt wird bei Neuerungen keine Schwierigkeiten haben. Wer sich “weigert” und argumentiert “das brauch ich alles nicht” steht irgendwann vor einem fast unlösbarem Problem.

      Doch zurück zum Thema. Das Problem mit dem DVD-Laufwerk ist individuell und hängt von den zig unterschiedlichen Konfigurationen ab die es gibt. Solange es Lösungen gibt ist das aber kein Problem!

  • Antworten
    Facke
    17. November 2012

    Grüß Gott,
    leider hat dieser Weg bei mir nicht funktioniert

    • Antworten
      Thomas Liedl Autor
      18. November 2012

      @Facke: Eine Garantie ist dieser Weg natürlich nicht, bei der Vielzahl an Konfigurationen dies es bei PC´s gibt. Ggf. ist in der Registry ein zweiter (fehlerhafter) Eintrag der entfernt werden muss. Dieser sollte – wenn es so ist – in unmittelbarer Nachbarschaft zum neu gemachten Eintrag stehen.

  • Antworten
    Simmefall
    19. November 2012

    Besten Dank für die perfekte Anleitung. Laufwerke wurden wieder erkannt und funktionieren. Nur iTunes Vers 10.7 will die Laufwerke noch nicht erkennen.

  • Antworten
    Simmefall
    20. November 2012

    Nach einem Firmware update der zwei optischen Laufwerke haben sie sich beim booten neu initialisiert und sie werden nun auch mit iTunes erkannt.

  • Antworten
    moin moin
    3. Januar 2013

    funktioniert leider trotzdem immernochnicht smilie

    • Antworten
      Thomas Liedl Autor
      4. Januar 2013

      @Moin Moin: Wie schon erwähnt, jedes System “tickt” anders. Eine Garantie für eine Lösung gibt es leider nie. Hast Du auf den eventuell doppelt vorhandenen Eintrag in der Registrierung geachtet? Wenn ja und es klappt dennoch nicht… sorry, dann fällt mir momentan auch nichts besseres ein.

  • Antworten
    Moin Moin
    4. Januar 2013

    Hallo, was meinen sie mit “Hast Du auf den eventuell doppelt vorhandenen Eintrag in der Registrierung geachtet?”, etwa sofern das ich den oben genannten Befehl zweimal eingeben muss? (reg.exe add “HKLMSystemCurrentControlSetServicesatapiController0″ /f /v EnumDevice1 /t REG_DWORD /d 0×00000001)
    MfG

    • Antworten
      Thomas Liedl Autor
      4. Januar 2013

      @Moin Moin: Nein, der Befehl muss nur einmal verwendet werden. Allerdings könnte es sein, dass eine “Dateileiche” in der Registry liegt. Diese müsste in jedem Fall entfernt werden. Zu finden ist diese Stelle unter der Adresse wie sie im o.g. Befehl angegeben ist. Die Registry ruft man mit den Befehl “regedit” auf. Drücke die Windowstaste und “W”, und gib in das Suchfeld “regedit” ein, dann gelangst Du zu diesem Programm. Das Bild zeigt Dir wie diese Stelle aussieht. Unter Punkt 2 sollte nur ein “Device” sein. Einen zweiten müsste man dann löschen. Achtung: In der Registry immer mit Bedacht vorgehen, das ist im Endeffekt eine Operation am offenen Herzen smilie
      Registry Screenshot

  • Antworten
    moin moin
    4. Januar 2013

    Hallo, was meinen sie mit “Hast Du auf den eventuell doppelt vorhandenen Eintrag in der Registrierung geachtet?”, etwa sofern das ich den oben genannten Befehl zweimal eingeben muss? (reg.exe add “HKLM\System\CurrentControlSet\Services\atapi\Controller0″ /f /v EnumDevice1 /t REG_DWORD /d 0×00000001)
    MfG

  • Antworten
    moin moin
    4. Januar 2013

    Hallo,
    vorsichtig sein ist gut, ich hatte vorher noch nie einen pc also würde ich wahrscheinlich auchnicht merken wenn ich das Betriebssystem löschen würde, insofern das irgendwie geht ;D
    Also soweit bin ich, aber sieht das bei mir anders aus und ich habe dieses “device” auchnicht ob das nun gut ist weiß ich nicht.
    http://www.pic-upload.de/view-17576185/image.jpg.html
    (Srceenshot kann ich noch nicht aber egal)
    Vielleicht hilft Ihnen das Bild ja.
    BG

    • Antworten
      Thomas Liedl Autor
      4. Januar 2013

      @Moin Moin: Jeder fängt mal klein an, ich bin sicher dass auch Sie das schaffen werden smilie . Nun zu dem Bild…: Sie sind noch nicht an der richtigen Stelle, sie müssen im Verzeichnis HKEY_LOCAL_MACHINE noch “tiefer rein”. Aufklappen geht immer mit dem kleinen Dreieck VOR dem Verzeichnisnamen!

      • Verzeichnis HKEY_LOCAL_MACHINE aufklappen
      • Unterverzeichnis SYSTEM suchen und aufklappen
      • Unterverzeichnis CurrentControlSet suchen und aufklappen
      • Unterverzeichnis Services suchen und aufklappen

      Jetzt sind Sie schon mal im richtigen Unterverzeichnis. Dort halten Sie Ausschau nach dem Punkt atapi, den Sie dann öffnen. Hier gibt es den Punkt Controller(), diesen nur einmal anklicken. Jetzt sieht Ihr Bild so aus wie das, welches ich eben gepostet hatte.

  • Antworten
    moin moin
    4. Januar 2013

    Hallo nochmal;D
    sie Beschreibung war 1a, alles auf anhieb gefunden, doch sie werden es nicht glauben es funktioniert dennoch immernochnicht. Das komische ist ja auch am Anfang hat es einaml funktioniert doch jetzt geht es aufeinmal nichtmehr, vielleicht ist das ja wichtig:
    LG

    • Antworten
      Thomas Liedl Autor
      4. Januar 2013

      @Moin Moin: Einen Versuch habe ich noch, wenn allerdings auch der fehlschlägt ist es mit meinen Ideen wirklich Ende smilie . Löschen Sie beide Devices im Verzeichnis atapi und starten Sie den Rechner neu. Erkennt der Rechner das Laufwerk ist alles ok, wenn nicht dann ggf. noch einmal den beschriebenen Befehl vom Artikel ausführen. Ich hoffe wir können dem Rechner damit jetzt Beine machen smilie

  • Antworten
    moin moin
    4. Januar 2013

    Am besten ich geh zu Bening und die sollen mir das da machen, kann ja nicht sein das dass immernochnicht geht…
    Trotzalledem bedanke ich mich sehr für die freundliche Hilfe, auch wenn sie mir nicht so viel gebracht hat.

    • Antworten
      Thomas Liedl Autor
      4. Januar 2013

      @Moin Moin: Wie schon erwähnt, jedes System ist anders und als Laie wird es dann schwer. Ferndiagnosen sind auch nicht unbedingt leicht zu stellen. Einen Blick drauf werfen lassen kann nicht schaden. Auch wenn meine Hilfe nicht zum Erfolg führt, sie war gerne geschehen smilie

  • Antworten
    Klaritti
    10. Januar 2013

    Da ich das gleiche Problem habe, habe ich den obigen Befehlt ausgeführt. Aber mein Laufwerk taucht leider nicht auf. An anderer Stelle wurde ich auf HKLM\System\CurrentControlSet\Control\Class\4D36E956-E325 (usw) gelenkt. Dort habe ich als Unterverzeichnis 0000, 0001, Configuration und Properties.
    Wenn ich versuche Properties zu öffnen erhalte ich die Fehlermeldung: Properties ist defekt. der Schlüssel kann aufgrund eines Fehlers nicht geöffnet werden. Detail: Zugriff verweigert.
    Liegt da vielleicht mein Problem? wäre für eine Hilfe sehr dankbar.

    • Antworten
      Thomas Liedl Autor
      10. Januar 2013

      @Klaritti: Entscheidend ist, dass “Operationen” dieser Art mit Administratorenrechten durch geführt werden. “Zugriff verweigert” lässt ggf. darauf schließen, dass diese nicht vorhanden sind. WIE dies zu bewerkstelligen ist habe ich im Artikel oben beschrieben. Mehr Lösungsvorschläge habe ich leider auf Grund der schon angesprochenen Unterschiedlichkeit von Systemen nicht smilie .

  • Antworten
    Wolf08
    19. Januar 2013

    Vielen vielen Dank für diesen Tipp.

    Ich kann es nur weiterempfehlen. SEHR GROSSE HILFE.

  • Antworten
    Frank
    15. März 2013

    Vielen Dank – hat sofort geklappt!!! Microsoft/ Hersteller (Sony) konnten nicht helfen. Ich liebe das Internet und ich freue mich über die Menschen, die ihr Wissen mit anderen kostenfrei teilen! Nochmals vielen Dank!!

  • Antworten
    Miguel
    26. März 2013

    Vielen Dank erstmal. Bei mir hat das nur temporär geholfen. Auf einer anderen Page habe ich dann ein MS-Tool gefundenm, damit ging es.
    Man möge nach “CDDVDWin8.diagcab” im Netz suchen.
    Grüße
    Miguel

  • Antworten
    Multi-Installer
    27. März 2013

    Herzlichen Dank. Hat 1A funktioniert. Wie kommt man auf sowas?
    Hat mir viel Grübeln und eine Neuinstallation erspart.

  • Antworten
    Christian
    31. März 2013

    Perfekt, vielen Dank!

  • Antworten
    15. Juni 2013

    … ich habe da ´mal eine kleine Website gebastelt, die das Problem beschreibt und Lösungen anbietet.

    http://minatho.tipido.net

  • Antworten
    29. Oktober 2013

    Hallo Thomas Liedl- echt profimäßig und ohne lang rum- kurze direkte Anleitung hat sofort gefruchtet. DANKE !!
    Die Söhne hatten auf W7 was weiß ich gremacht Verknüpfungen weg nichts ging mehr – Wollte nicht lang rum machen also schnell upgrade auf w8 pro 64. Dan die Ernüchterung Plötzlich erkennt der das DVS Laufwerk nichtmehr obwohl im Bios eindeutig erkannt – eingetragen. Nun solche Leute wie Du machen das Leben wieder einfacher. Denn ich hab jaa genug mit meinem Büro und dem Bürosystem zu tun oft genug gibt’s da Probleme mit NAS und sonstwas- Jetz auch noch mit den Söhnen PCs rummmachen war für mich wie Wltuntergang- man hat ja sonst nichts zu tun…- Die ERLÜSUNG DEINE ERARBEITUNG – DEIN KOMMENTAR- DANKE – Auch die Erklärung kurz und bündig direkt- Befehl hat sofort erfolgreich angenommen – DANKE !!!

    • Antworten
      Thomas Liedl Autor
      29. Oktober 2013

      Freut mich wenn der Artikel weiterhelfen konnte. Danke für den Kommentar.