Mit der Umgestaltung meines Blogs hätte ich zu gerne noch „meine eigene Suchmaschine“ mit integriert – Google CSE. Leider klappt das nicht so wie vorgehabt und ich muss dies nach hinten verschieben. Zwar gibt es Möglichkeiten mit einem Plugin, aber auch dies funzt nicht so benutzerfreundlich (Stichwort Pop-Up). Zwei sehr gute Anleitungen habe ich bei e-byz und Blogverdiener gefunden – der Einbau scheitert trotzdem daran, dass die Suchergebnisse nicht auf Anhieb angezeigt werden.

Gibt man einen Suchbegriff im Header ein erscheint zwar die angelegte Seite, diese allerdings leer mit einem neuen Suchfeld. Erst wenn dieses ausgefüllt wird werden Ergebnisse geliefert. Damit würden sich Besucher eher ärgern als dass es nützt. Aufgeschoben ist nicht aufgehoben, Google CSE ist eben noch „beta“ :wink: .

Werbung

15 Kommentare zu „Einbau von Google CSE verschoben“

  1. Speziell was das Twenty Eleven Theme angeht, da bemühe doch mal die Suchmaschine in Englischer Sprache nach dem Thema. Da findest du oft mehr, als wie wenn in Deutsch suchst. Mir sind da damals etliche Ergebnisse zu untergekommen, wobei ich allerdings etwas anderes Themenverwandtes suchte.

    Irgendwie so die Richtung „wordpress google ces“ oder „wordpress twenty eleven ces“ oder auch gerne voll ausgeschrieben. Weil manchmal tut sich die Suchmaschine etwas schwer mit bestimmten Abkürzungen. ;)

    1. @Stefan: Da war ich auch schon bei, leider bisher ohne einen entscheidenden Hinweis der zum Ziel führte. Irgendwann werde ich schon etwas auftreiben was letztlich auch funktioniert.

      @Alex: „Aufräumen“ war mir bei der Umstellung sehr wichtig und es ist ganz gut gelungen.

  2. Na hier sieht’s ja vielleicht mal aufgeräumt aus! :D
    Gratulation. Ich liebe solche Themes. Angenehm zu lesen, aufgeräumt, schlicht und einfach… nur gut! :)
    Bis bald und beste Grüße, Alex

    1. @ixiter: Nichts anderes wäre mein Ziel. Doch wie Du selbst sehen kannst führt eine Suche zwar zur „Ergebnisseite“, die allerdings leer bleibt – wieso und weshalb auch immer. Fällt Dir dazu was ein? :denk:

  3. Ich sehe, dass dein WP sämtliche Parameter entfernt und dann die Ergenisseite erneut aufruft. Also aus einem https://www.nicht-spurlos.de/ macht dein WP immer ein .. und das kann dann nicht funktionieren.

    Auf deiner Suchergebnisseite vermisse ich auch ein Stückchen Javascript von Google, dass mit den Werten ein iframe füttern soll, dass dann sie Suchergebnisse anzeigen soll.

    1. @Ixiter: Alles was Du siehst ist genau nach Anleitung eingebaut, entnommen von Google CSE. Inzwischen habe ich zig Anleitungen gelesen. Die eine behauptet dies, die andere jenes und eine dritte widerruft alles bisher dagewesene. Was nun stimmt kann ich nicht mehr beurteilen. Google CSE selbst behauptet sogar, den iFrame erst gar nicht mehr zu unterstützen… Programmierer müsste man sein :cool: .

  4. Ich müsste da jetzt gucken und lesen was CSE alles meint. Meins ist nach irgendwelchen Codes von vor ein paar Jahren gemacht und es sollte auch immer noch funken. :D

    Das Hauptproblem bei dir ist, dass die Parameter aus den URLs verschwinden, obwohl die WP so ziemlich egal sein sollten. Da solltest du mal gucken, welches Plugin dass veranstaltet. Wenn das behoben ist, sollten auch deine Suchergebnisse zu sehen sein, denke ich.

    1. Eben das ist es, die Anleitungen die ich alle fand beruhen auf Google CSE als es noch den iFrame gab. Diese Anleitungen sind größtenteils so nicht mehr ausführbar, weil es die beschriebenen Schritte bei Google CSE so gar nicht mehr gibt. Das macht es nicht unbedingt einfacher. Wenn ich es richtig deute sind die Parameter der „searchform.php“ weg. Ich habe da – eben nach Anleitung – u.a. folgendes stehen:

      Antworten
  • Ja, komische Sache. Es ist jedenfalls kein spezielles Problem, dass nur die Suche betrifft. Es ist ein generelles Problem, dass dein Request/URL Handling betrifft. Mehr kann ich so auch nicht sagen. Da müsste ich mehr Zugriff haben, usw. usf.

    1. @Ixiter: Es gibt wahrscheinlich soviele Lösungen wie es WordPress-User gibt…. ich habe meine gefunden. Ohne abschalten von Plugins usw. Ich werde darüber berichten, vielleicht hilft es jemanden weiter der genauso festhängt. Dir auf jeden Fall Danke für Deine Bemühungen und Ratschläge. :yes:

  • Jo .. ich habs ja hier live verfolgt und gesehen wann es endlich geklappt hat :) Würde mich natürlich brennend interessieren, wie du das gemacht hast. :)

    1. Erklärung folgt ganz sicher, nur heute eben nicht mehr. Ich will das dann auch ganz genau erklären und bebildern dass es auch eine Hilfe ist :wink: .

  • Kommentar verfassen

    Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

    Du kannst Dich informieren lassen wenn es Folgekommentare gibt. Du kannst aber auch abonnieren ohne zu kommentieren.

    Scroll to Top